N’utilise plus la rechercheV sur Excel

0
1930

Il y a quelque temps de cela j’ai lancé un sondage pour voir combien d’entre vous utilise les différentes fonction de recherche dans Excel. 

Il s’avère que la plupart d’entre vous qui ont répondu au sondage utiliser la fonction rechercheV et ben dans cette vidéo je vais tenter de vous convaincre d’utiliser autre chose que la rechercheV. 

Ce n’est pas tout car nous allons aussi optimiser au maximum la fonction rechercheV afin de la rendre la plus dynamique possible. 

mise en place des données 

Alors nous avons ici un tableau qui contient des données d’utilisateur que nous allons utiliser afin de récupérer le nom, prénom et code de l’utilisateur. 

iddateFirst nameLast nameCode
113-04-22ArielleKlein1000
214-04-22CameronBalistreri1010
315-04-22ClarindaMiller1020
416-04-22CaitlynHansen1030
517-04-22DonnBailey1040
618-04-22EnriqueRenner1050
719-04-22ThaddeusSmitham1060
820-04-22LawerenceO’Connell1070
921-04-22RegeniaBatz1080
1022-04-22LouArmstrong1090
1123-04-22RosalynKovacek1100
1224-04-22LauraStark1110
1325-04-22MikkiWolff1120

nous allons faire une recherche sur l’id afin de retrouver les informations de nos utilisateur qui se trouve dans la cellule H2

La rechercheV 

nous allons utiliser la fonction de recherchV afin de récupérer le prénom d’un utilisateur. Pour cela nous allons devoir mentionner la formule suivante.

=SIERREUR(RECHERCHEV(H2;Tableau1;3;0); » »)

Comme on peut le voir ici c’est que la fonction est très facile à mettre en place et avec une gestion d’erreur on peut éviter d’avoir des messages d’erreur si la valeur n’est pas retrouvée.

Mais ici nous avons un petit souci c’est que si on tente d’ajouter une nouvelle donnée dans notre base de données alors la valeur recherchée n’est plus bonne et on doit impérativement modifier notre formule qui n’est pas vraiment géniale.

Cela nous pouvons le régler en ajoutant une autre fonction dans notre formule de recherche comme suite

=SIERREUR(RECHERCHEV(H2;Tableau1;EQUIV(« first name »;Tableau1[#En-têtes];0);0); » »)

Il nous reste encore un dernier problème avec notre forme que nous ne pouvons pas résourde avec la rechercheV. La fonction part toujours de gauche à droite, il n’est pas possible de changer de direction par exemple si on ne veut plus rechercher sur l’id mais sur le code de l’utilisateur, notre rechercheV ne fonctionne plus ici.

La fonction Index et Equiv

Pour résoudre le problème précédent nous pouvons utiliser une combinaison de la fonction index et equiv qui nous permet de rechercher des données n’importe où dans notre base de donnée. vous pouvez retrouver plus d’info sur cette formule ici https://www.youtube.com/watch?v=FiKVcAVmKw0

Nous pouvons rendre la formule très dynamique comme suite.

=SIERREUR(INDEX(Tableau1[Last name];EQUIV(H2;Tableau1[id];0)); » »)

Alors c’est une formule un peu plus longue que la rechercheV mais elle est plus robuste et permet de persister quand notre base de donnée changera.

La fonction rechercheX

Si on dispose de la version 2021 d’Excel ou plus on peut utiliser la fonction recherchX qui va faire la même chose que la combinaison d’index et equiv sauf qu’elle est plus facile à utiliser. vous pouvez retrouver des informations détaillées de la fonction dans l’article, Une formule de recherche qui surpasse toutes les autres. 

Avec la fonction rechercheX on ne fait appelle qu’à une seule fonction et non pas une longue formule qui contient de multiple fonction ou une erreur n’est pas exclue.

=RECHERCHEX(H2;Tableau1[id];Tableau1[Code]; » »;0;1)

Faites-moi savoir dans les commentaires si je suis arrivé à vous convaincre d’utiliser autre chose que la fonction rechercheV pour vos projets excel. 

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.