Comment utiliser la fonction si avec plusieurs condition

33
174257

La fonction si nous permet de vérifier si une certaine condition est atteint dans Excel afin de faire afficher un résultat. Et dans ce tutoriel Excel nous allons voir comment utiliser la fonction si avec plusieurs condition comme à l’aide de deux fonction que nous allons ajouter notamment la fonction Et et la fonction ou

Tout cela nous allons le voir avec un petit suivi de stock. Nous allons contrôler s’il y à du stock, nous allons aussi placer des critère dans notre stock en plaçant un Min et un Max. avec ces critère nous allons afficher un message différent.
quand le stock est bas nous allons le mentionner ainsi que si le stock est trop haut.

puis nous allons contrôler s’il y a une commande qui vas être réceptionner qui comblera le stock min ou pas.

Condition si :

Nous allons commencer avec la fonction SI().

La fonction SI fonctionne en 3 phase.

  • La première phase nous allons effectuer un test
  • La seconde phase consiste de faire quelque chose si le résultat du test est rempli donc vrais.
  • La troisième phase consiste de faire quelque chose  si le résultat du test est faux.

Dans notre premier test nous allons voir s’il y a du stock oui ou non.

=SI(F7>0;VRAI;FAUX)

Désormais nous allons effectuer plusieurs test et donner un résultat selon chaque test.

=SI(F7<=0; »manque de stock »;SI(F7<G7; »stock trop bas »;SI(F7>H7; »stock trop haut »; »Stock OK »)))

Pour rendre la condition plus visible il est possible d’ajouter une ligne avec alt+entrée

=SI(B6=0; »manque de stock »;
SI(B6<C6; »stock trop bas »;
SI(B6>D6; »stock trop haut »; »stock OK »)))

Ce qui rend la formule plus lisible.

Condition ET :

désormais nous allons ajouter une condition. et cette condition devrais tester si plusieures test donnent un résultat vrais.et si tout les test donne un résultat vrai. alors nous affichons un résultat,, par contre si l’un des test n’est pas vrais alors nous affichons un autre résultat.

c’est à dire que dans notre exemple nous voulons afficher le texte la livraison comblera le manque:

critère 1 : que le stock actuelle est plus bas que le critère min du stock.

critère 2 : quand une livraison est sur le chemin et qu’il couvrira le stock min apres etre additionner avec le stock actuelle.

si les deux condtion sont rempli alors nous affichons notre texte sinon nous allons ajouter un autre teste et voir s’il y a une livraison nous allons afficher le texte suivant si c’est vrais la commande ne comblera pas le manque, si il n’y a pas de commande nous affichons rien.

=SI(ET(B6<C6;B6+E6>=C6); »la livraison comblera le manque »;””)

pour aller plus loins nous pouvons afficher que la livraison ne comblera pas le stock ainsi que la livraison provoquera un surstock.

=SI(ET(C5<D5;C5+F5>=D5); »La livraison comblera le manque. »;
SI(ET(F5<>0;C5<D5); »La livraison ne comblera pas le manque »;
SI(ET(F5<>0;C5+F5>E5); »la livraison provoquera un surstock »;
«  »)))

Condition ou :

désormais nous allons faire une autre condition de la fonction si. et il s’agit de la condition OU.

avec cette condition nous allons vérifier si l’un des condition est vrais alors nous affichons un message si l’un des condition n’est pas vrais donc faux alors on affiche un autre message.

nous allons dans notre exemple contrôler si le stock est trop bas ou trop haut alors nous allons afficher une alerte

=SI(OU(B6<C6;B6>D6); »Stock Alert »; » »)

dans notre exemple nous allons l’utiliser dans une mise en forme conditionnel afin de créer une allert. mais avant cela nous allons créer une zone de remarque. qui devrait afficher ce qui se trouve dans la partie fonction si ou dans la partie condition ET avec la formule suivante.

=si(I5<>””;I5;H5)

À placer dans une mise en forme conditionnelle.

copier la partie OU de la condition OU et placer la dans la mise en forme conditionnelle en rouge

ajouter une autre mise en forme si la zone n’est pas en alert et qu’un message est afficher.

sélectionner le tout et désormais ajouter un tableau et chaque article que vous allez ajouter recevrons ce contrôle que nous venons de crée avec la fonction si et ces condition.

voila je vous ai donné toute les information que je possède à propos de comment utiliser la fonctions si avec plusieurs condition. si vous avez encore des question je vous invite à lire le wikipedia sur la fonction si dans google ou vous pouvez tout simplement le poster ici en bas dans les commentaire et on se retrouve dans une prochaine vidéo.

33 Commentaires

  1. Bonjour
    Quelle formule peut on utiliser pour avoir les information suivantes;
    Age compris entre 18 et 49 ans si c’est une femme (2)
    Age compris entre 18 et 49 ans si c’est un homme (1)
    Age de 50 et plus si c’est femme (2)
    Age de 50 et plus si c’est un homme (3)
    dans une seule colonne

  2. Bonjour
    Quel formule on peut utiliser pour remplir les vides par les nombres en dessus car pour le nombre 1474 il y a beaucoup de vide en dessous

    5 02/10 au 08/10
    27/09
    773 27/09 au 28/09
    29/09
    1019 27/09 au 28/09
    29/09
    1334 03/10
    27/09 au 01/10
    1474 01/10
    27/09
    28/09
    29/09
    30/09

  3. bonjour, Tout d’abord merci pour ce tuto très enrichissant.
    J’ai un souci avec la condition si, j’ai des numéros de licence dans une colonne A, je veux extraire dans une autre colonne B une partie de ce numéro. jusque là, je sais faire:=SI(I4= » »; » « ;STXT(I4;1;3)) ou =SI(I16= » »; » « ;STXT(I16;1;3)*1) mais le problème est que les numéros sont de source différente et la partie que je cherche à extraire (le département) n’est pas situé à la même place.
    Exemple: 08996573871 et 42890110011. Je cherche à extraire le 89 dans ce cas de figure mais ça peut être un autre département ou rien si pas indiqué. J’ai essayé différentes formules sans sucés et je capitule

  4. Je souhaiterais pouvoir déterminer une valeur conditionner par une distance qui varie et des capacités qui varient aussi. par exemple pour distance inférieur à 50km et capacité compris entre 2 et 10, valeur est égale à 50000, et pour distance compris entre 50 et 200 km, et capacité entre 10 et 50; le valeur est égale à 145000. et d’autres variations. Aidez moi s’il vous plait.

  5. Bonjour,
    Je n’arrive pas à obtenir le résultat souhaité cad soit « 0 » ou « réassort » en fonction de certaines conditions. En effet, je souhaiterais qu’il soit noté « réassort » dans la cellule AI4 lorsque la cellule C4 est identique à C3 et que la cellule P4 est également identique à BU3 et que AG4=0, si une de ces 3 conditions est fausse (comme par exemple dans la cellule AG4 il peu être noté soit « 0 » ou « nouveau ») alors, je souhaiterais qu’il soit noté « 0 » j’ai tenté plusieurs formules mais ça ne fonctionne pas le résultat est « réassort » même si l’une de ces 3 conditions n’est pas remplie…
    Je vous remercie de bien vouloir m’aider car je sèche…

    Valérie

  6. Bonjour,

    La formule rentrer dans « Tranche d’âge » ne fonctionne pas, elle m’indique la tranche « De 65 à 99 ans » pour tout le monde ?
    Comment est-ce possible

  7. Bonjour

    Je sollicite votre aide, car je ‘arrive pas a modifier cette formule.

    Je voudrais dans la formule ci dessous remplacer TARIFCF par la valeur texte d’une Cellule (L2) avec 2 choix (TARIFCF ou TARIFCE) .

    =SI(B4= » »; » »;(RECHERCHEV(B4;TARIFCF!A:H;2;FAUX)))

    Merci de votre Aide

  8. Comment entre un formule excel comme suit:
    Je voudrai avoir un formule comme :Si salaire de base inferieur à 350 000 alors;2000 le resultat mais entre 350 000 à 400 000 donc 5% le resultat à afficher

  9. Bonjour
    J’ai une énigme depuis presque un moi avec Excel 2016 en utilisant la fonction logique Si avec 5 conditions.
    J’ai procédé comme suit:
    =si(F1>=18; »Excellent »;si( F1>=17, »Très bien »; si(F1>=14; »bien »;si(F1>=12; »Assez bien »;si(F1>=10; »Passable »; »Pas de mention »))))).
    A chaque fois que je valide avec la touche entrer; Excel m’indique un message d’erreur indiquant comme quoi qu’il a rencontré une erreur.
    Je sollicite votre aide et c’est un peu urgent.

    • Bonjour,

      Il faut utiliser la formule si.conditions pour plusieurs conditions.
      Voici la formule à mettre pour que ça fonctionne:

      =SI.CONDITIONS(F1>=18; »Excellent »;F1>=17; »Très Bien »;F1>=14; »Bien »;F1>=12; »Assez Bien »;F1>=10; »Passable »;1; »Pas de mention »)

      Le 1 est pour valider les conditions (si elles sont « vrai, donc « 1 », alors ça écrira excellent ou très bien ou…), sinon « pas de mention)

  10. Bonjour,
    Je suis novice sur excel et j’ai du mal à utiliser la condition SI. voici mon PB:
    Si A1 et B1 vides alors je n’affiche rien dans C1; Sinon A1 vide j’affiche B1 dans C1 et si B1 vide j’affiche A1 dans C1.

    Merci de votre aide

  11. Bonjour
    J’ai deux cellules avec une date et dans le troisième de désire avoir une date de rappel 14 jours plus tard
    donc a2 égale quand j’ai parlé au client
    a3 égale quand j’ai laissé un message au client
    dans la trois je veux une date de rappel pour l’une ou l’autre des date
    Voici la formule, elle fonctionne si je ne traite qu’une cellule mais quand je veux une date pour l’une ou l’autre ca fonctionne pas
    Merci
    =SI(ESTVIDE([@[SUIVI
    parler avec client]]; » »;[@[SUIVI
    parler avec client]]+14);SI(ESTVIDE([SUIVI
    Laisser message]]); » »;[@[SUIVI
    Laisser message]]+14)

    je ne sais pas si je dois utiliser le OU ou plus de si

    ca fait une heure que je travaille ca et ca ne fonctionne pas

    J’attends de vos nouvelles

  12. Bonjour, Je suis novice en excel mais j’essaye de me débrouiller pour des choses simples.
    Pourquoi le résultat de cette formule est « #NAME? »?

    Voici la formule:
    = SI(D5<1;"";((B5/2)-D5))

    Voici ce que je voulais faire en mots:
    Si D5 est plus petit que 1 alors ne rien mettre (dans la case) sinon, faire cette formule: ((B5/2)-D5)

    Quelqu'un peut-il m'aider?

    Merciiii 🙂

    Isabelle

    • Bonjour Isabelle,
      votre formule est bonne la seul question que j’ai c’est la langue de votre version D’Excel est-ce que vous utiliser une version FR ou une version EN ?
      si vous remplacer le « si » avec un « if » est-ce que cela fonctionne ?

  13. Bonjour
    Dans Excel, je voudrais créer une formule qui serait :
    à chaque fois que dans 3 cellules différentes une somme est saisie (peu importe laquelle) le résultat soit 1
    Merci pour votre aide

  14. bonjour moi j’ai un soucis pour rédiger une formule

    =100+(T62)

    je voudrais que si la cellule T62 est négative soit déduit de la valeur 100 et ne soit pas cummuler a la valeur 100 si positive

    cordialement Jm Visacoski

    • bonjour moi j’ai un soucis pour rédiger une formule
      =100+(T62)
      je voudrais que si la cellule T62 est négative soit déduit de la valeur 100 et ne soit pas cummuler a la valeur 100 si positive
      cordialement Jm Visacoski
      je voulais dire cellule a1=100 + celle t62= -50 je voudrais que la cellule devienne 50 ou lorsque la cellule t62 =20 la cellule reste 100
      ma formule actuelle est:100+($T61)

  15. BONJOUR

    je souhaiterai faire un tableau de mes achats en sortant la tva
    20% 10% et 5.5%
    est ce que je peux mettre par exemple
    dans ma colone tva 20, 10 ou 5.5 et faire faire la formule pour sortir la tva ?
    = SI E=20;D/100*1.2 et les 2 autres formules en même temps ? comment ?
    merci d’avance

  16. Comment écrire en excel une formule à 3 conditions (Pays, sexe, type de logement):
    Si je reste au Canada que je suis un gars qui reste dans une maison = 1000$
    Si je reste au Canada que je suis un gars qui reste en appartement = 500$
    Si je reste au Canada que je suis un gars qui reste chez parent = 0$
    Si je reste au Canada que je suis une fille qui reste dans une maison = 800$
    Si je reste au Canada que je suis une fille qui reste en appartement= 400$
    Si je reste au Canada que je suis une fille qui reste chez parent = 0$
    Si je reste ailleurs qu’au Canada cout non disponible

  17. bonjour d’abord Mercie pour vos tuto mon problème est la fonction voila ma formule
    j13 = List déroulant profil
    j9 = List ID
    Coté Propriétaire parfait
    coté Locataire valeur Faux
    =SI(J13= »Propriétaire »;INDEX(Attestation_Chaudière_Gaz[Nom du Propriétaire Ou Commercial];EQUIV(J9;Attestation_Chaudière_Gaz[ID];SI(J13= »Locataire »; INDEX(Attestation_Chaudière_Gaz[Nom Contact des lieux l’installation];EQUIV(J9;Attestation_Chaudière_Gaz[ID]))))))
    Mercie d’avance
    cordialement jp

  18. bonjour a tous,
    j’ai une énigme auquel je fais fasse depuis le début de semaine ..
    je voudrais afficher dans ma case le permis qu’il faut en fonction des véhicules (de leur poids) et de la reporque(du poids également)..
    cette formule me donne par exemple : BEFAUX, comment faire pour enlever ce « FAUX » ..
    =SI(F8= »VL »;SI(F11= »NON »; »INTERDIT »;SI($C9<=0,75;SI(F10<=3,5;"B";SI(F10<=4,25;"B96"));"BE")))&SI(F8="PL";SI($C9<=0,75;"C1";SI(F6<=7,5;"C1E";"CE")))

    Merci pour la personne qui me délivrera

    Cordialement
    KM

  19. Bonjour Merci pour votre tuto. Je voudrais utiliser cette formule mais ça ne marche pas =SI(E9= » »;0;
    SI(E9>=F9;N9*F9/E9;
    SI(E9>=G9;N9*G9/E9;
    N9))). je demande votre assistance.

    • Bonjour « VAL », par curiosité je viens d’essayer et moi ça fonctionne j’ai du reprendre tes («  ») du début car la fonction ne les reconnaissait pas.
      Tu devrais réessayer avec le double (« ).

      cordialement

      PS: je ne suis pas professionnel, si le problème persiste j’en serais navré.

  20. Bonjour, merci pour ce tuto mais comment faire avec une formule.
    Je voudrais écrire si A3=T et J3>=0 alors faire le calcul J3-K3
    Voici ce que j’ai noté mais cel me dit « NOM »?
    =SI(ET(C35=co;J35>=0); »J35-K35″; » »)
    Et du coup comment faire pour
    et Si A3 est différent de T alors case vide.
    Merci d’avance pour votre aide.

    • Bonjour Patricia,
      vous pouvez faire cela avec une condition si comme suite
      =SI(C17<20;C17*0,2;C17*0,1)
      qui va simplement vérifier si le nombre dans la cellule C17 est plus petit que 20 alors multiplie par 0.2 sinon C17 * 0.1
      par contre ici si le montant est 20 alors il sera multiplier par 0.2
      si vous voulez que la multiplication ne se fait pas quand le nombre est 20 alors placer la formule suivante.
      =SI(C17<20;C17*0,2;SI(C17>20;C17*0,1; » »))

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.