Comment utiliser la fonction si avec plusieurs condition

0
13344

La fonction si nous permet de vérifier si une certaine condition est atteint dans Excel afin de faire afficher un résultat. Et dans ce tutoriel Excel nous allons voir comment utiliser la fonction si avec plusieurs condition comme à l’aide de deux fonction que nous allons ajouter notamment la fonction Et et la fonction ou

Tout cela nous allons le voir avec un petit suivi de stock. Nous allons contrôler s’il y à du stock, nous allons aussi placer des critère dans notre stock en plaçant un Min et un Max. avec ces critère nous allons afficher un message différent.
quand le stock est bas nous allons le mentionner ainsi que si le stock est trop haut.

puis nous allons contrôler s’il y a une commande qui vas être réceptionner qui comblera le stock min ou pas.

Condition si :

Nous allons commencer avec la fonction SI().

La fonction SI fonctionne en 3 phase.

  • La première phase nous allons effectuer un test
  • La seconde phase consiste de faire quelque chose si le résultat du test est rempli donc vrais.
  • La troisième phase consiste de faire quelque chose  si le résultat du test est faux.

Dans notre premier test nous allons voir s’il y a du stock oui ou non.

=SI(F7>0;VRAI;FAUX)

Désormais nous allons effectuer plusieurs test et donner un résultat selon chaque test.

=SI(F7<=0;”manque de stock”;SI(F7<G7;”stock trop bas”;SI(F7>H7;”stock trop haut”;”Stock OK”)))

Pour rendre la condition plus visible il est possible d’ajouter une ligne avec alt+entrée

=SI(B6=0;”manque de stock”;
SI(B6<C6;”stock trop bas”;
SI(B6>D6;”stock trop haut”;”stock OK”)))

Ce qui rend la formule plus lisible.

Condition ET :

désormais nous allons ajouter une condition. et cette condition devrais tester si plusieures test donnent un résultat vrais.et si tout les test donne un résultat vrai. alors nous affichons un résultat,, par contre si l’un des test n’est pas vrais alors nous affichons un autre résultat.

c’est à dire que dans notre exemple nous voulons afficher le texte la livraison comblera le manque:

critère 1 : que le stock actuelle est plus bas que le critère min du stock.

critère 2 : quand une livraison est sur le chemin et qu’il couvrira le stock min apres etre additionner avec le stock actuelle.

si les deux condtion sont rempli alors nous affichons notre texte sinon nous allons ajouter un autre teste et voir s’il y a une livraison nous allons afficher le texte suivant si c’est vrais la commande ne comblera pas le manque, si il n’y a pas de commande nous affichons rien.

=SI(ET(B6<C6;B6+E6>=C6);”la livraison comblera le manque”;””)

pour aller plus loins nous pouvons afficher que la livraison ne comblera pas le stock ainsi que la livraison provoquera un surstock.

=SI(ET(C5<D5;C5+F5>=D5);”La livraison comblera le manque.”;
SI(ET(F5<>0;C5<D5);”La livraison ne comblera pas le manque”;
SI(ET(F5<>0;C5+F5>E5);”la livraison provoquera un surstock”;
“”)))

Condition ou :

désormais nous allons faire une autre condition de la fonction si. et il s’agit de la condition OU.

avec cette condition nous allons vérifier si l’un des condition est vrais alors nous affichons un message si l’un des condition n’est pas vrais donc faux alors on affiche un autre message.

nous allons dans notre exemple contrôler si le stock est trop bas ou trop haut alors nous allons afficher une alerte

=SI(OU(B6<C6;B6>D6);”Stock Alert”;””)

dans notre exemple nous allons l’utiliser dans une mise en forme conditionnel afin de créer une allert. mais avant cela nous allons créer une zone de remarque. qui devrait afficher ce qui se trouve dans la partie fonction si ou dans la partie condition ET avec la formule suivante.

=si(I5<>””;I5;H5)

À placer dans une mise en forme conditionnelle.

copier la partie OU de la condition OU et placer la dans la mise en forme conditionnelle en rouge

ajouter une autre mise en forme si la zone n’est pas en alert et qu’un message est afficher.

sélectionner le tout et désormais ajouter un tableau et chaque article que vous allez ajouter recevrons ce contrôle que nous venons de crée avec la fonction si et ces condition.

voila je vous ai donné toute les information que je possède à propos de comment utiliser la fonctions si avec plusieurs condition. si vous avez encore des question je vous invite à lire le wikipedia sur la fonction si dans google ou vous pouvez tout simplement le poster ici en bas dans les commentaire et on se retrouve dans une prochaine vidéo.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.