Comment Calculer ses heures de travail pour la semaine.

5
7504

Dans ce cours d’Excel nous allons voir comment calculer ses heures de travail pour la semaine de plus que le prix de l’heure.

Pour calculer les heures de travaille: 

nous allons dans un premier temps calculer le nombre d’heures en retirant les pause.

=(D9-C9)+(F9-E9) 

ici nous allons donc avoir le temps de travaille total moins les heures de pause.

désormais nous voulons contrôler si le temps de travaille est de 8h ou moins.
si ce n’et pas le cas c’est à dire plus de 8 heures alors on indiquer 8h et les heures supplémentaires, nous allons devoir les calculer plus tard.

=SI((D9-C9)+(F9-E9)>8/24;8/24;(D9-C9)+(F9-E9))

donc si nous lisons ce code ça di –> si le calcule est plus grand que 8h alors on affiche 8.
Si ce n’est pas le cas alors on affiche le résultat qui est inférieure à 8h.

Pour Calculer les heures supplémentaire. 

dans la partie Heure supplémentaire nous voulons voir combien de temps en plus des 8h sont en surplus..

=SI((D9-C9)+(F9-E9)>8/24;((D9-C9)+(F9-E9))-G9;””)

Ici nous avons la condition suivante.
si le calcule est plus grand que 8h alors ont reprend le calcule – le résultat de du temps normal (qui serra de 8h).
par contre si le résultat n’est pas plus grand que 8h. alors on affiche rien.

Calculer le total d’heure de travaille et supplémentaire.

le premier reflex et qui n’est pas mauvais c’est d’utiliser la fonction somme.

=SOMME(G9:G15)

c’et tout à fais exacte mais comme nous pouvons le voir. cela n’indique pas le temps total.

je vais reprendre l’exemple avec 5 jours de travaille avec 8h de travaille.

le résultat serra : 16:00
pourtant nous savons que 5x8h ne font pas 16h de travaille en total mais bien 40h.

l’explication est assez simple vous allez voir. Excel va calculer comme suite.

  1. 8h
  2. 16h
  3. 24h –> minuit
  4. 8h –> une nouvelle journé
  5. 16h

pour demander à excel de cumuler les heures il faut changer le format.
click droit –> format de cellule –> personnalisée

ici nous allons ajouter dans TYPE [h]:mm

le faite de placer le h entre ces deux [ ] signe signifie qu’Excel devra accumuler.

Calculer le salaire de la semaine. 

ici ça va de soit comme les heures cumulé nous fessons pour les tarif normal.

=G18*C4

Oela ! nous avons gagner pour 40h de travaille que 16€. pourtant 40h x 10€/h font bien 400€.

ici encore 1h dans excel est = 0.0416667 en nombre. donc si nous voulons calculer un nombre il faut le multiplié par 24.
donc quand nous changeons la formule par =G18*G4*24 nous avons bien 400€

voila désormais vous savez comment calculer ses heures de travail sur Excel. et comme toujours n’oublier de noter ce Court dans les commentaires. d’ici la nous nous retrouvons dans un prochain court.

 

5 Commentaires

  1. bonjour je recherche une feuille de temps sans le prix de l’heure , uniquement jour,semaine et mois avec possibilité de noté les chantier par jour et me donne le cumul de mes heures normal et supplémentairement sur la base de 35 h
    je ne trouve rien qui ressemble a ca

  2. Bonjour,
    Merci pour votre tableau qui peux mettre très utile!! (Ps: vos tutos sont super à suivre!!) J’ai juste 2 soucis: Je travail avec des heures irrégulières et j’ai des majorations de temps (Ex. Entre 00:00 et 06:00 +40% et entre 22:00 et 23:59 + 25%)
    Il s’ajoute à cela que nous finissons des fois après minuit (Ex: début 15:00 fin de service: 00:30
    Merci de m’indiquer si vous avez des tutos qui réponde à ses questions.
    Meilleures salutations
    Mathias

    • pour votre première demande je ne pourrais vous aidez c’est compliquer à écrire en simple texte et malheureusement je n’ais à ce jour aucun tuto qui couvre votre problème. mais je peux vous donnez une piste, c’est de travailler en groupe. c’est à dire que vous allez devoir controler si vos heures de travaille tombe dans la première tranche horaire et si oui combien de temps. donc vous allez devoir travailler avec la fonction SI et la condition ET

      pour calculer le total après minuit il suffit d’ajouter la fonction MOD() exemple :
      dans A1 22:00 et dans A2 03:00 –> pour afficher la différance placer la formule suivante dans A3 =MOD(A2-A1;1) et le résultat devrais être 5H

      voila j’espère que cela vous aidera.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.