Chart de Progression Persnnalisable avec 3 niveaux de couleur.

0
1206

Une charte de progression dans un tableau de bord il est souvent essentiel de voir la progression afin de pouvoir mesurer si nous somme dans les objectifs définit oui ou non. Ou de savoir notre niveau de progression face à l’objectif.
C’est pourquoi nous allons voir dans ce petit tutoriel comment réaliser un graphique ou une chart de progression qui est programmer avec 3 niveaux est chaque niveau correspond à une couleur.


Le layout.

réaliser un layout comme afficher si dessous.

C4 –> Réaliser : en D4 –> 55%
C7 –> Niveau 1 : en D7 –> 45%
C8 –> Niveau 2 : en D8 –> 55%
C9 –> Niveau 3 : en D9 –> 100%

Les niveaux :

Puis nous allons commencer à vérifier si le résultat réalisé est plus petit ou égal au niveau 1 alors nous allons l’afficher le résultat à coter.

Pour une meilleure visuelle changer le format en %

Et le contrôle ce fait avec la formule suivante.

=SI(D4<=D7;D4;””)

Pour le second niveau nous allons contrôler si la valeur est plus grande que le premier niveau ou plus petite que le second niveau.

=SI(ET(D4>D7;D4<=D8);D4;””)

Et pour le troisième niveau nous allons tout simplement contrôler si le résultat est plus grand que le second niveau alors il devient vert.

=SI(D4>D8;D4;””)

Calculer le reste.

Comme nous allons avoir besoin d’afficher le total réaliser face à l’objectif nous allons devoir afficher combien il reste.

Et cela nous allons le faire avec la formule suivante.

=MAX(1;D4)-D4

Ici c’est simple nous demander d’afficher le max entre 100% et le résultat qui se trouve en D4. Si la valeur est inférieur a 100% alors le résultat serra 100% – la valeur de D4 par contre si la valeur est supérieure à 100% alors on prend le résultat de D4 – D4 se qui donne 0% de reste.

Une autre solution est de faire =si(D4>=1 ;0 ;1-d4)

Le graphique/chart

Sélectionner le résultat au reste puis inséré –> graphique anneau.

Nous allons travailler étape par étape.

Placer un % inférieur que le niveau 1 dans réaliser.

Désormais sélectionner la barre qui représente le résultat du niveau 1 et changer la couleurs selon celui qui est afficher dans le tableau.

Et faite de même pour les 2 autres niveaux.

Une fois les 3 niveau choisi changer le reste en gris léger ou blanc.

Déformais retirer toute les information du graphique.

Ajouter la progression.

Pour ajouter le % de progression il faut inséré -> forme -> zone de texte.

Et la nous allons lier la zone de texte au Résultat du niveau.

Puis nous allons crée 2 autre pour le niveau 2 et 1

Cliquer sur la première zone de texte puis maintenir la touche CTRL enfoncé et glisser avec le bouton gauche de la souri pour crée une copie.

Voila désormais il faut changer les information et la couleur selon le niveau

Regrouper le tout.

Déformais nous allons regrouper le tout .

Et ici nous allons masque les cadres et placer les zone de texte au milieux du graphique.

il ne reste plus qua personnaliser le tout.

voila désormais vous aussi vous pouvez réaliser une chart de progression. si vous avez des question ou des remarques surtout n’hésiter pas de les poster dans les commentaires.

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.