2 Méthodes pour rechercher des données sur multiple page

0
393

Il m’arrive souvent de devoir rechercher des données sur multiple page, mais les formule de recherche classique ne sont pas vraiment conçu pour faire cela. Mais ne vous en fait pas nous allons voir 2 méthodes pour rechercher des données sur multiple page.

Avec la première méthode nous allons indiquer sur quel page il faut rechercher les données et dans la seconde méthode nous allons voir comment nous pouvons automatiser cela et ne plus devoir indiquer la page

Vous pouvez retrouver le liens du fichier ICI

https://youtu.be/YlNDJCR3-yM

Explication de la fonction rechercheV

Comme vous le savez surement il existe plusieurs méthodes de recherche et si vous êtes curieux de les découvrir vous pouvez en retrouver ici 10 formules excel les plus utiliser 

Et donc nous allons voir cette fameuse recherchev qui consiste à rechercher des informations dans une plage de donnée et d’afficher les informations de la colonne.

=RECHERCHEV(B4;Fruit!B3:D8;2;0)

Alors rien de bien compliquer nous allons chercher la valeur qui se trouve dans la cellule B4 et la comparer avec la première colonne de la plage de donnée B3 à D8 sur la page Fruit, s’il y a une correspondance on affiche se qui se trouve dans la 2eme colonne et on indique aussi que nous voulons une recherche exacte et non pas approximatif.

Le problème ici c’est que nous pouvons uniquement faire une recherche sur 1 seul page et non pas sur d’autre page.

Mise en place rechercher des données sur multiple page

Il est grand temps de mettre en place la recherche sur de multiple page.

Nous allons devoir disposer notre information de la même façon sur chaque page.

Recherche sur multiple page

Cela ne veut pas dire que vous ne pouvez ajouter plus de critère à votre base de données mais que les titre qui corresponde à chaque page soient à la même place. Cela veut dire que sur chaque page dans la cellule B3 il faut indiquer le nom, dans C3 le Prix et dans D3 le nombre

Une fois cela fait nous allons nommer nos bases de données comme le nom de notre page c’est important.

Recherche sur multiple page

Puis nous allons créer un tableau qui comporte les noms de nos pages et que nous allons nommer Page.

Recherche sur multiple page

Sur notre page Recherche nous allons placer une liste déroulante dans la partie Catégorie, la source de notre liste serra Page.

Recherche sur multiple page

Première méthode de recherche sur multiple page

L’objectif ici c’est de placer le mot dans la partie Recherche puis de sélectionner dans quelle catégorie il faut rechercher et d’afficher le prix et le nombre.

Alors dans la fonction recherchev nous allons devoir indiquer grâce au nom de plage ou il faut chercher et cela nous allons devoir intégrer la fonction indirecte dans la formule recherchev.

Et elle fait quoi cette fonction indirecte ? hé ben elle permet de faire référence à une cellule ou une plage de donnée depuis un texte. Dans notre exemple le texte se trouve dans sous la case catégorie ce qui nous donne la formule suivante.

=SIERREUR(RECHERCHEV($B$4;INDIRECT($C$4);2;0);””)

Désormais si nous placer dans recherche pomme et que nous sélectionnons la catégorie Légume rien ne s’affiche par contre si nous changeons la catégorie en Fruit nous avons le prix de la pomme qui s’affiche

Recherche sur multiple page

Et on peut faire la même chose pour le nombre sauf qu’il faut changer la 2eme colonne en 3

Seconde méthode de recherche sur multiple page

Notre seconde méthode est un peux plus compliquer car nous allons devoir travailler avec de multiple fonction dans la formule car nous voulons rechercher sur tous les pages et non les sélectionner.

Rechercher des données sur multiple page avec la fonction NB.SI une valeur est existant si c’est le la fonction NB.SI ira la compter et ainsi on saura sur quelle page elle se trouve.

Pour montrer comment cela va fonctionner nous allons placer à coter de notre tableau avec les noms de page la formule suivante

=NB.SI(INDIRECT(“”&J4&”!$B$3:$d$10″);$B$4)

Et on obtient le résultat suivant

Recherche sur multiple page

Si on transforme la fonction indirecte en page de donnée on recois le résultat suivant.

=NB.SI(Fruit!$B$3:$B$10;Recherche!$B$4)

Mais grâce à indirect on peut dire à Excel prend la valeur texte qui se trouve dans la cellule et place la valeur dans la formule.

Alors ici on peut voir que la première ligne est 1 donc elle contient le résultat rechercher et que les autres ont une valeur 0 donc le mot pomme ne s’affiche pas sur ces pages.

Désormais nous pouvons donc utiliser une autre formule de recherche pour afficher l’emplacement d’une recherche la fameuse INDEX & EQUIV mais encore cela ne serra pas une simple recherche car nous allons devoir contrôler plusieurs pages donc nous allons créer une recherche de tableau qui faudra donc valider avec la combinaison des touche MAJ+CTRL+ENtree

=INDEX(Page;EQUIV(1;NB.SI(INDIRECT(“”&Page&”!$b$3:$d$10″);$B$4);0))

Si on valide la formule avec la combinaison des 3 touches on obtiens le résultat Fruit. Se qui veut dire que notre plage de donnée se trouve sur la page fruit. Il nous suffit seulement d’implémenter cette information avec indirect() dans notre recherchev et notre formule est terminé.

=SIERREUR(RECHERCHEV($B$4;INDIRECT(“”&INDEX(Page;EQUIV(1;(NB.SI(INDIRECT(“”&Page&”!$b$3:$d$10″);$B$4));0))&”!$b$3:$d$10″);2;0);””)

Et voilà pour la recherche d’un jeu, ne pas oublier de valider avec MAJ+CTRL+ENTREE

Suivi horaire

Désormais on peut voir que la première méthode n’affiche rien car la catégorie est mise sur Légume par contre avec la seconde méthode on cherche sur chaque page pour afficher le résultat.

Alors faite moi savoir dans les commentaires se que vous avez pensé de se court et si vous allez l’utiliser dans vos applications. D’ici là je vous souhait une bonne journée et on se retrouve sur un prochain cours. Salut

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.